Rolls MX56 AV Minimixer optimieren

Das Labor ist der richtige Ort um spezielle Projekte inkl. Fehlersuche zu diskutieren.

Moderator: kubi

Rolls MX56 AV Minimixer optimieren

Postby hardtrail » Fri Apr 06, 2012 11:02 pm

Ein Freund vn mir würde gerne einen kleinen batteriebetriebenen Mixer modifiziert haben. Den Schaltplan findet ihr hier: http://imageshack.us/photo/my-images/68 ... matic.jpg/
Gewünscht war, dass INST/MIC OUT nicht das Summensignal, sondern nur das MIC (CH2) und INST (CH4) führt.
Signale, mit denen das Teil beschickt wird, ist ein DI Bass und ein Synthesizer.
Also habe ich im Prinzip die Verstärkerschaltung aus dem Schaltplan um U2a auf Lochraster aufgebaut und die Out Buchse nur mit diesem Signal beschickt. Soweit funktioniert es auch.
Aber ich habe einiges an Verbesserungsbedarf entdeckt.
- Das Gerät wird z.Zt. mit einer 9V Batterie betrieben. Wenn es das Gehäuse zulässt würde ich gerne eine 2. 9V Batterie einbauen, die Spannun auf 7...8V stabilisieren um dem Gerät ein Bisschen mehr Headroom zu geben.
- Bei 9V machtg Phantompower wohl wenig Sinn, also R24,25 entfernen
- Warum sind die Kondensatoren am Differenzverstärker für den MIC Eingang so bemessen, dass ab ca. 6 kHz die Höhen beschnitten werden? Hier werde ich die passenden Kondensatoren berechnen und einbauen.
- Kann mir jmd sagen, warum C3 und C16 bzw C4, C17 in Reihe sind? Ist das eine art "bipolarer Elko"?

Ich habe mit den Mikrofonkanal in Multisim aufgebaut und simuliere fleißig. Dafür habe ich noch 20 Tage Zeit, dann wars das leider mit der Evaluierung :lol:

Hat noch jemand Vorschläge, was man noch optimieren kann? (Bitte nicht den Mülleimer vorschlagen...)
Letzte Frage: Wie modelliere ich mir ein Mikrofon als Eingangssignal? Dh was sind übliche Pegel und Innenwiderstände meiner Ersatzspannungsquelle?
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby jensenmann » Sat Apr 07, 2012 8:51 am

Der Biasstrom fließt aus dem Opamp raus in C3 und C4 rein. D.h. er lädt beide positiv auf. C16 und C17 sehen aber die Phantomspeisung und werden von der positiv geladen. Das Problem bei nur einem Kondensator anstelle von zwei ist, dass der Biasstrom den Elko in die andere Richtung lädt, wie die Phantomspeisung und somit das Elko beim Betrieb ohne P48 verkehrt herum gepolt wird und jede mene Nichtlinearitäten erzeugt. Technisch gesehen wäre die Lösung hier noch besser, wenn man für alle 4 Elkos einen Erdbezug mit Widerständen von den -Anschlüssen gegen 0 herstellen würde.
C1, C6, C18, C13, C14 sollte besser Folie sein, dürfen auch gerne ein klein bisschen größer gewählt werden. U1B sollte ein FET Opamp, U1A jedoch ein bipolarer Opamp sein, um die Verstärker im Bereich geringstmöglichen Rauschens zu betreiben. Für beide macht Sinn, dass es welche sind, die wenig Offset haben, da alles direktgekoppelt ist.
C3/4/16/17 dürfen gerne bis zu 100uF/63V sein. C2/8 können etwas kleiner werden.
R16/23 werden üblicherweise eher 33-47 Ohm sein, um Kapazitive Last zu entkoppeln und C5 und C15 können gerne bis zu 470uF sein.
Die Summierwiederstände sind ganz schön groß, das führt zu Rauschen. Mach die ruhig kleiner. U2A/B muß ein bipolarer sein, am besten so ein supermodernes Ding ohne Offset, mit einem OSI bei 10kOhm oder kleiner.
Jens
jensenmann
 
Posts: 2667
Joined: Fri Mar 24, 2006 8:20 pm
Location: Karlsruhe, BRD

Postby hardtrail » Sat Apr 07, 2012 10:11 am

Danke für die Erläuterungen. Die je zwei Kondensatoren in den Signalleitungen des Mic in kann ich dann doch auch durch einen bipolaren Elko ersetzen?
Worin äußert sich ein Vergrößern von C5,15? Wenn es eine geringere Dämpfung der tiefen Frequenzen ist, sollte ich das in der Simulation sehen können.
Welchen Wert schlägst du für die Summierwiderstände vor?

Welche Möglichkeiten habe ich, den Phasengang etwas zu begradigen? Multisim gibt mir eine Phase von -80 bis 80° über den Frequenzbereich von 20-20kHz an....
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby jensenmann » Sat Apr 07, 2012 10:36 am

Bipolare Elkos gibt es nicht bis 63V zu kaufen. Da du aber keine 48V Phantom hast und vermutlich die nicht von extern aufschalten willst ist das kein Problem. Der Nachteil von BipolElkos ist dass es eine Reihenschaltung zweier Elkos ist und somit der ESR halb so gut ist, wie bei einem einzelnen. Im Grunde genommen gibt es nur eine Kompromisslösung, kein Optimum:
1. Wenn du Phantom dauerhaft angeschaltet lässt wäre ein normaler Elko mit + Richtung Phantomeinspeisung die beste Lösung. Dadurch wird das Elko niemals umgekehrt polarisiert.
2. Brauchst du niemals Phantompower, dann dreh den Elko um, mit + in Richtung des Opampeingangs. Dann wird er durch den Biasstrom richtig herum polarisiert.
3. Willst du P48 schalten können, dann gibt es folgende Lösungen:
Wie 1. und du lebst mit dem rückwärtspolarisierten Elko im abgeschalteten P48 Zustand. 2. ist keine Option, da Phantompower als Rückwärtspolarisation das Elko kaputt macht, auch mit nur 9V. 3. du übernimmst die Schaltung vom Original oder benutzt bipolare Elkos oder 4. bastelst an die gemeinsamen - Anschlüsse der Elkos einen Widerstand gegen 0V, damit ein Bezug zu Masse da ist und die Elkos eine genau definierte Spannung (in die richtige Richtung) haben.
Jegliches Vergrößern der Koppelkondensatoren linearisiert den Phasengang im Bassbereich. Wenn du simulierst probier auch mal ob ein Vergleinern der Bandbreitenbegrenzung (470pF) nach oben hin etwas bringt. Benutzt du modernere Chips dann musst du auch nicht so wüst die Bandbreite begrenzen, weil die etwas stabiler sind.
Probier für die Summierwiderstände mal 10k aus, das hilft auf jeden Fall mit 3dB Verbesserung beim Rauschen und bringt die Opamps noch nicht um.
Jens
jensenmann
 
Posts: 2667
Joined: Fri Mar 24, 2006 8:20 pm
Location: Karlsruhe, BRD

Postby hardtrail » Sat Apr 07, 2012 11:31 am

Ist dir ein signifikanter Unterschied zwischen dem TL072 und dem NE5532 bekannt? Mit dem tl072 funktionierte die Simulation nicht. Irgendwie sind mir diese Computerprogramme suspekt!
Jedenfalls läuft die Simulation (der originalen Schaltung) nun und ich mache mich mal an die Berechnung / Überprüfung der Verstärkungen um zu sehen, ob nicht doch irgendwo was schief läuft.
Ich sehe schonmal, dass meine Ausgangsspannung die Betriebsspannung von 9V deutlich überschreitet, ich habe ca. 60Vpp bei 300mVpp Input. Zumindest stimmt das mit dem Bode Diagramm überein, welches mit 60dB Verstärkung anzeigt.
Du nutzt nicht zufällig multisim und magst mal kurz schauen, wo der Wurm drin ist?
DAS ist die Schaltung...
Image
By stefatronik

Hier ist das Bode- Diagramm
Image
By stefatronik
Deutlich zu sehen ist die Phase, die mit eigentlich auch noch nicht gefällt. Habe aber gerade keine Idee, wie ich die noch begradigen kann...
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby Harpo » Sat Apr 07, 2012 1:01 pm

Du hast da schon einige Merkwürdigkeiten drin...
R11 und R12 werden gleich groß sein, damit die Referenzspannung in der Mitte ist (und nicht auf 4,02V). Mit einem Kondensator über R12 sollte das auch stabiler sein.
C2,3,4 sind uF, nicht F und C1-4 jeweils um Faktor 10 zu klein. (momentan mit 5uF ist der HPF mit den 600R+332R auf 34Hz).
Der Kompensations-Cap C5 (und C6) ist um Faktor 10 zu groß (LPF momentan auf 16,9kHz).
R7 und R8 können mit 'nem NE5532 auch um Faktor 10 kleiner, C7 dann 100pF.
Der tiefere Sinn über eine Notwendigkeit von R13 entzieht sich meiner Kenntnis (war früher mal ein 100K log Poti).
Das Du einige Widerstände als Serien-Ensemble hast (R1+R2, R15+R3, R16+R4), mag Layout-Gründe haben, anderenfalls kostet es nur mehr und braucht mehr Platz.
Wie in Multisim dargestellt, hat der Differenzverstärker +26,6dB, die 2.Stufe hat +13,2dB, insgesamt +39,8dB ohne eine Möglichkeit, weniger Gas geben zu können. Mit 'nem Synthi-Pegel am Eingang kommt da vermutlich nur Clipping raus.
mische lauter - Ohren wachsen nach
Ist mir Scheißegal wer dein Vater ist. Solange ich am Angeln bin, gehst Du hier nicht übers Wasser !
User avatar
Harpo
 
Posts: 463
Joined: Thu Jun 21, 2007 10:22 pm
Location: Rahden NRW

Postby hardtrail » Sat Apr 07, 2012 1:56 pm

Du hast da schon einige Merkwürdigkeiten drin...

Stimmt, aber bis auf die Kondensatoren, wo mir das µ abhanden gekommen ist, entspricht das der original- Schaltung.
Der 100k R13 soll das voll aufgedrehte Poti aus dem original Schaltplan "simulieren".
Den Tiefpass am ersten OPV habe ich auch schon erkannt und behoben mit den vorgeschlagenen 47pF ebenso den Hochpass mit den eingangsseitigen Kondensatoren. Die 3k Widerstände stammen von der Phantomspeisung die ich entferne, da ohnehin nur 9V.
Den NE5532 hälst du für besser als den 4558? Ich müsste jetzt die Datenblätter fragen verlasse mich aber gerne auf deine Erfahrung.
Den Spannungsteiler für 4,5V passe ich später in dem Gerät an, ist ja recht einfach da mal kurz zu messen.
Die Serienwiderstände verschwinden natürlich.
Ist die eingestellte Verstärkung für einen Mikrofoneingang korrekt / ausreichend? Einstellbar wird sie vor der zweiten Stufe durch das Poti, das ich natürlich nicht wegoptimiere.
Die Line- Eingänge passe ich in einem zweiten Arbeitsschritt an.

Danke für die Unterstützung. Freut mich, dass ich endlich mal Ansätze aus dem Studium in der Praxis anwenden kann UND dass ich mit meinen Vermutungen nicht ganz daneben lag :)
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby hardtrail » Sat Apr 07, 2012 2:21 pm

Hat einiges gebracht, siehe:

VORHER:
Image


NACHHER:


Image

Sieht doch schonmal ganz brauchbar aus. Ich hoffe, die Verstärkung ist nicht zuuu übel aber die zu verringern ist ja auch nicht sooo der act...
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby Harpo » Sat Apr 07, 2012 3:16 pm

hardtrail wrote:Der 100k R13 soll das voll aufgedrehte Poti aus dem original Schaltplan "simulieren".

dann nimm ein 100K Poti aus Multisim, mach 'nen Doppelclick auf das Symbol und wähle einen Buchstaben für 'Key' aus, z.B. 'G'. Das Drehen des Potis kannst Du dann im laufenden Simulator durch Drücken der Taste 'G' in Richtung 100% oder mit [shift]'G' in Richtung 0% verändern.

.., da ohnehin nur 9V.

sprachst Du nicht von 'Wenn es das Gehäuse zulässt würde ich gerne eine 2. 9V Batterie einbauen, die Spannun auf 7...8V stabilisieren um dem Gerät ein Bisschen mehr Headroom zu geben'? Der RC4558 hätte gerne mindestens +/-5V, vieleicht reichen auch +/-4,5V, aber wenn die Batterie schlapp macht könnte sich das schnell merkwürdig anhören. Die Stabilisierungs-Idee würde ich in die Tonne werfen. Du bist weit von den Versorgungsspannungsgrenzen der Opamps entfernt und würdest zwei LDO-Regler brauchen um vieleicht etwas zu erreichen. 2x9V in Serie an die Ursprüngliche Stelle und R11/R12 teilen das gleichmäßig auf, daß die Referenz in der Mitte bleibt, auch wenn nur eine der Batterien schapp machen sollte. Diese Ub/2 Referenzspannung zu puffern würde mehr bringen als irgendein Reglerensemble, tut aber auch ohne.

Den NE5532 hälst du für besser als den 4558? Ich müsste jetzt die Datenblätter fragen...

Datenblatt befrage ist immer eine gute Idee. Der 5532 hat weniger Rauschspannung, größere GBW, größere Anstiegsgeschwindigkeit, kann größere Last antreiben, ist problemlos und bezahlbar erhältlich, falls mal defekt, braucht aber mehr als das Doppelte an Ruhestrom, verglichen mit einem RC4558. Hattest Du nicht erst TL072er geplant?

Die Serienwiderstände verschwinden natürlich.

Statt der beiden 600Rs würde ich die auf jeweils 10-20K für Line-Signale vergrößern und für Mic-Signale die mit 'nem DPST kurzschließen, so daß nur noch die 332Rs als Eingangswiderstände bleiben. Alternativ 'nen z.B. 20dB Pad statt der 600Rs, braucht aber einen DPDT Schalter und einen Widerstand mehr.
Ist die eingestellte Verstärkung für einen Mikrofoneingang korrekt / ausreichend? Einstellbar wird sie vor der zweiten Stufe durch das Poti, das ich natürlich nicht wegoptimiere.

Hängt vom Mikro und der davor produzierten Radaumenge ab, sollte aber größtenteils funktionieren. Ohne die 600Rs macht die erste Stufe LOG(20000/332)*20=35,6dB oder 'nen Voltage Gain von 60. Mit 18V Batteriegas schwingt ein 5532 auf typ +/-7V, dh.bei Signalamplitude von größer (7V/60)/Wurzel(2)=>82mV sollte der Pad aktiviert werden, sonst übersteuert die Stufe. Ein übersteuertes Signal kannst Du mit dem Poti zwar leiser machen, es bleibt aber geclippt.
mische lauter - Ohren wachsen nach
Ist mir Scheißegal wer dein Vater ist. Solange ich am Angeln bin, gehst Du hier nicht übers Wasser !
User avatar
Harpo
 
Posts: 463
Joined: Thu Jun 21, 2007 10:22 pm
Location: Rahden NRW

Postby hardtrail » Sun Apr 08, 2012 12:47 pm

2x9V in Serie an die Ursprüngliche Stelle und R11/R12 teilen das gleichmäßig auf, daß die Referenz in der Mitte bleibt, auch wenn nur eine der Batterien schapp machen sollte. Diese Ub/2 Referenzspannung zu puffern würde mehr bringen als irgendein Reglerensemble, tut aber auch ohne.

Du hast Recht, das klingt nach der besten Lösung. An Regelung / Stabilisierung dachte ich usprünglich an eine Lösung mit Z-Diode. Aber das wird nicht nötig sein, und wenn es vorher mit einer 9V Batterie geklappt hat, dann wird es das erst Recht mit zweien tun! Bleibt nur noch die Gehäusefrage, der ich Morgen auf den Grund gehe (oder ein spezieller Akku?)

Hattest Du nicht erst TL072er geplant?

Um ehrlich zu sein: Bisher habe ich noch garkeinen OPV geplant. Original sind 4556 drin. Die habe ich bei Multisim nicht gefunden. Also habe ich irgendeinen OPV gewählt, der in der Bibliothek vorhanden war und den ich für einen gängigen Typen halte. Einen geeigneten OPV nur mit Hilfe der Datenblätter auszuwählen traue ich mir grad nicht zu. Dafür weiß ich zu wenig über einige der Tabellenangaben. Deswegen hatte ich auf Empfehlungen gehofft. Ich weiß, keine ideale Lösung. Aber wie groß ist denn tatsächlich der Einflus des OPV? Wenn ich meinem Professor glauben darf, ist das eher vernachlässigbar.
Ich habe mir die beiden Datenblätter NJM4556 und NE4558 mal angeschaut aber wirklich schlauer bin ich jetzt auch nicht. Ehrlich gesagt habe ich auch keine Ahnung, wie ich die Parameter im vorliegenden Falle bewerten muss. Fakt ist, dass ich wohl den 4558 verwenden kann falls ich den 4556 nirgends bekomme. Was meinst du?
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby Harpo » Sun Apr 08, 2012 2:24 pm

hardtrail wrote:Original sind 4556 drin.

... die für den Typ NJM4556AD schon ab +/-2V Supply laufen, GBW von 8MHz haben, bis zu +/-70mA in 150R Last anschieben können, 9mA Ruhestrom saugen und mit 8nV/sqrt(Hz) eine ähnliche Rauschspannung wie die NE4558 haben, der NE5532 bei 1kHz aber nur 5nV/sqrt(Hz).
Der NE4558, wirklich NE.., nicht RC4558?, möchte mindestens +/-5V Supply, hat 'ne GBW von 3MHz, schiebt nur 1/10tel der Last an, braucht aber nur 2,5mA Ruhestrom. Der NE Typ macht nur 2MHz und rauscht
mit 25nV/sqrt(Hz).
Wenn die erste Stufe einen Voltage gain von 60 oder +35dB hat, sollte der NJM4556 auf max.133kHz, der RC4558 auf 50kHz oder der NE4558 auf max.33kHz mit C5 kompensiert werden, sonst oszillierts. Wenn Dir die -3dB bei 33kHz (30° bei 20kHz) oder 50kHz (22° bei 20kHz) zu wenig sind, teile diese Stufe auf z.B. 2* Wurzel(60)=+17,8dB Gain-Stufen auf, oder nimm 'nen Opamp mit mehr GBW.
mische lauter - Ohren wachsen nach
Ist mir Scheißegal wer dein Vater ist. Solange ich am Angeln bin, gehst Du hier nicht übers Wasser !
User avatar
Harpo
 
Posts: 463
Joined: Thu Jun 21, 2007 10:22 pm
Location: Rahden NRW

Postby hardtrail » Tue Apr 10, 2012 9:11 am

Ich habe gestern bestellt, den 4556 gab es bei Bürklin leider nicht. Da es ohnehin nur um einen OPV in der zweiten Stufe für die Modifikation (siehe erster Post: Inst. Ausgang soll nur bestimmte Signale erhalten) geht, setze ich einfach einen Sockel auf die Lochraster Platine und schaue, was passiert. Ich habe gestern auch nochmal mein Glück mit den Datenblättern versucht. Was hälst du vom TL072? Ich behaupte, dass es egal ist, ob ich dort einen FET oder BJT Typ einsetze oder irre ich? Eingangsseitig würde ich den FET bevorzugen wg. Eingangswiderstand.
Da ich nun auch die Versorgungsspannung angehoben habe (2 9V Batterien passten tatsächlich noch ins Gehäuse) wäre auch der NE5532 möglich.

Die Unterschiede zwischen den unterschiedlichen OPVs habe ich jedenfalls unterschätzt. Dieses Topic war sehr lehrreich für mich :cool:
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Postby hardtrail » Sat Apr 14, 2012 2:30 pm

Beim ersten Test war es dann noch noch spannend! Abhängig von der Stellung der einzelnen Kanäle fing der Input 4 (Instrument) an zu schwingen, dass der OPV übersteuerte und schließlich garkein Ausgangsignal mehr erzeute. Ich habe festgestellt, dass das Problem am ehesten besteht, wenn ich alle Kabnäle auf 0 drehe. Im Endeffekt lag es wohl daran, dass meine 0V Referenz über einen Spannungsteiler erzeugt wurde und der Pufferelko (47µ) darüber so langsam geladen wurde, dass die dadurch entstandende Zeitkonstante irgendwie mit dem Eingang Schwingungen erzeugte. Ich ahbe den Spannugnsteiler nun mit 2X 6,8 kOhm gebaut, nun klappt es besser. Dummer Fehler, ich habe nach und nach jede Änderung wieder Rückgängig gemacht und mich immer weiter gewundert....
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes


Return to Das Labor

Who is online

Users browsing this forum: No registered users and 5 guests

cron